Phusion white papers Phusion overview

Phusion Passenger 2.1.2 (final) released

By Hongli Lai on March 13th, 2009

Phusion Passenger is an Apache module for deploying Ruby on Rails web applications, and is mainly focused on ease of use and stability.

Recent changes

Phusion Passenger is under constant maintenance and development. We are pleased to announce Phusion Passenger version 2.1.2. This is a major improvement over the 2.0.x series. Please see the 2.1.1 (beta) announcement for a list of improvements compared to 2.0.x.

Phusion Passenger 2.1.2 final is compatible with Rails 2.3, while older versions of Phusion Passenger are not!

2.1.2’s release was strategically planned for today because Rails 2.3 final is going to be released very soon. So if you’re running any Rails 2.3 apps, then you should upgrade to Phusion Passenger 2.1.2.

The following things have changed since 2.1.1 beta:

Fixed various compilation issues
We fixed many different compilation issues that occur on FreeBSD, NetBSD and (Open)Solaris. Phusion Passenger will now also try harder to autodetect the correct APR install and the correct Apache command tools.
Worked around a restart issue on OpenSolaris
An OpenSolaris-related issue, which causes Phusion Passenger to restart the backend application on every request even when restart.txt doesn’t exist, has been worked around. We suspect that this issue is
caused by a bug in the OpenSolaris compiler toolchain.
Improved fatal error diagnostics
A central part of Phusion Passenger is the ApplicationPoolServerExecutable. If it goes down then Phusion Passenger won’t work anymore until you restart Apache. We’ve gone into great lengths to ensure that this part is stable, but some people report that ApplicationPoolServerExecutable could crash, although the reasons have been unknown so far.

ApplicationPoolServerExecutable will now print a gdb backtrace of itself when it crashes. This allows us to better diagnose potential problems.

Documentation
Documentation has been improved.
Various other small bugfixes
Please read the git commit list for details.

How do I upgrade to 2.1.2?

Via a gem

Please install it with the following command:

gem install passenger

Next, run:

passenger-install-apache2-module

Please don’t forget to copy & paste the Apache config snippet that the installer gives you.

Via a native Linux package

John Leach from Brightbox has kindly provided an Ubuntu 8.04 package for Phusion Passenger. The package is available from the Brightbox repository which you can find
at:

http://apt.brightbox.net

Add the following line to the Third Party Software Sources:

deb http://apt.brightbox.net hardy main

(The simplest way to do that is to create a file in /etc/apt/sources.list.d/ containing the deb instruction, and then run ‘apt-get update’).

Once you’ve done this then you can install Phusion Passenger by running:

apt-get install libapache2-mod-passenger

(Note that John is currently packaging 2.1.2, so it might take a while before this release shows up in the apt repository.)

Final

Phusion Passenger is provided to the community for free. If you like Phusion Passenger, please consider sending us a donation. Thanks!

Hongli Lai Ninh Bui