Phusion white papers Phusion overview

Phusion Passenger DOES support Ruby 2.0

By Hongli Lai on June 6th, 2013

We’ve lately encountered some confusion among users about whether Phusion Passenger supports Ruby 2.0. In the announcement for Release Candidate 2 we mentioned that we had problems with Ruby 2.0, but unfortunately we didn’t word that accurately enough, which caused confusion among users. We hope that this blog post will clear things up.

  • Phusion Passenger does support Ruby 2.0, since version 4.0.0.
  • In the RC 2 announcement we merely claimed that we encountered a lot of bugs (for example this one) in Ruby 2.0.0 itself, and that we therefore would not recommend using Ruby 2.0.0 yet. These bugs have got nothing to do with Phusion Passenger. Phusion Passenger supports Ruby 2.0.0 regardless of what bugs Ruby 2.0.0 has.
  • A lot of Ruby 2.0.0 bugs have been fixed in 2.0.0-p195, but not all. We still get segmentation faults on OS X when using Ruby 2.0.0, with and without Phusion Passenger. These bugs are not incompatibility problems with Phusion Passenger, but are bugs in Ruby 2.0.0. We therefore cannot recommend Ruby 2.0.0 yet, but it’s possible that it works fine for you. You are free to use Ruby 2.0.0 with Phusion Passenger if you so choose.

Update: it looks like manually installing from the tarball makes the crash go away. This makes it likely that the crash was caused by RVM’s compilation process. Thanks a lot for the help by @nalsh.

  • http://tisba.de/ Sebastian Cohnen

    Looks like the first issue you mentioned has been fixed in 2.0.0-p247 according to the changelog: http://svn.ruby-lang.org/repos/ruby/tags/v2_0_0_247/ChangeLog. Are there any other issues you are aware of?

  • http://www.phusion.nl/ Hongli Lai

    None that we’re aware of. Since the assistance by @nalsh and the RVM authors, Ruby 2.0 has been working fine.

  • http://www.clippingpathworkhouse.com/ Mrs. Mimi Akter

    Great blog. this is really informative blog. Thanks

  • Tony Zhao

    I couldnt install passenger through gem because it was trying to download files that don’t exist in your repo. It seems like it has an extra “-gnu” in the file name, for example:
    *** Could not download https://oss-binaries.phusionpassenger.com/binaries/passenger/by_release/4.0.40/rubyext-ruby-2.0.0-x86_64-linux-gnu.tar.gz: The requested URL returned error: 404

    Any idea why?

  • http://www.phusion.nl/ Hongli Lai

    That has already been fixed in the latest version.

  • Tony Zhao

    Okay, yes, I successfully built it with version 4.0.41, which I cloned from github. Would be nice to have it in the gem repo :) Thanks!