Passenger 5.0.29: Ubuntu 16.04 packages, Nginx 1.10.1, Docker logging improvements

Version 5.0.29 of the Phusion Passenger application server for Ruby, Node.js, Meteor and Python has been released. It's also available through apt on »

Xcode 7.3.1 fixes build & remote code execution

When Apple released version 7.3.0 of Xcode, Passenger users on OSX started experiencing a crash issue after compiling Passenger. Version 7.3.1 no »

Passenger 5.0.28: rails server, Nginx 1.10, memleak fix

Version 5.0.28 of the Phusion Passenger application server for Ruby, Node.js, Meteor and Python has been released. Besides a few improvements it contains »

Passenger 5.0.27: fixes, fixes, improvements

Version 5.0.27 of the Phusion Passenger application server for Ruby, Node.js, Meteor and Python has been released. It has some interesting fixes for »

Passenger 5.0.26: high concurrency tweaks, WebSockets improvements, SELinux improvements, bugfixes

Version 5.0.26 of the Phusion Passenger application server for Ruby, Node.js, Meteor and Python has been released. It features a bunch of improvements »

Passenger 5.0.25: Rails 5 and Action Cable integration, crash fixes

Version 5.0.25 of the Phusion Passenger application server for Ruby, Node.js, Meteor and Python has been released. This release introduces much better Rails »

Passenger 5.0.24: WebSocket fixes, Nginx 1.8.1, improvements

Version 5.0.24 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. It resolves some issues surrounding websockets, »

Passenger 5.0.23: bug fixes, Node.js WebSocket improvements

Version 5.0.23 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. It contains a few improvements and »

Union Station ♥ Node.js: request introspection with Passenger 5.0.22

The latest Passenger release contains some exciting new monitoring features for Node.js applications. One of these is that Passenger can now deep-inspect applications to measure »

Security advisory: CVE-2015-7519 header overwriting (medium severity)

It was discovered by the SUSE security team that it was possible, in some cases, for clients to overwrite headers set by the server, resulting in »

Passenger 5.0.22: Union Station support for Node.js, CVE-2015-7519, bugfixes

Version 5.0.22 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. This release contains a security fix »

Passenger 4.0.60: CVE-2015-7519, OS X El Capitan support, minor changes

Version 4.0.60 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. This is mainly due to CVE-2015-7519, »

Passenger 5.0.16: fixes Node.js/io.js regression and other bugs

Version 5.0.16 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. If you hadn't already, be sure »

Passenger 5.0.14: OpenSSL CVE-2015-1793

Version 5.0.14 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. This is a hotfix due to »

Phusion Passenger 5.0.10: improved admin tools, fixed bugs

Version 5.0.10 of the Phusion Passenger application server for Ruby, Python, Node.js and Meteor has been released. If you hadn't already, be sure »