Phusion Passenger 4.0.58 released

We've just released version 4.0.58 of the Phusion Passenger application server for Ruby, Python and Node.js. This release fixes two minor packaging-related issues.

Debian packages no longer require Ruby 1.9

Due to a bug in the package specifications, Debian packages used to require Ruby 1.9, even if you already have newer Ruby versions installed from APT (e.g. through the Brightbox repository). This bug has now been fixed. The Phusion Passenger Debian packages now require some Ruby interpreter, but it doesn't care which version.

Enterprise: fixed Flying Passenger in the Debian packages

Phusion Passenger Enterprise's Flying Passenger mode was broken in the Debian packages. It wouldn't work if you try to use it with a Ruby interpreter that isn't installed by APT. This has been fixed.

Installing or upgrading to 4.0.58

OS X OS X Debian Debian Ubuntu Ubuntu
Heroku Heroku Ruby gem Ruby gem Tarball Tarball

Final

Phusion Passenger's core is open source. Please fork or watch us on Github. :)

comments powered by Disqus