We are considering dropping support in Passenger for RHEL/CentOS 6, Debian 7 and Ruby 1.8. These distributions are very old, so it's getting increasingly hard to maintain support for these. They also slow down our development process and thus slow down future improvements.

By dropping support for old operating systems, we'll be able to use C++11, which should simplify our codebase. By dropping Ruby 1.8, we'll be able to upgrade the gems we use during development and testing, and we'll be able to remove various compatibility code.

Since 2014, Ruby 1.8(.7) no longer receives security patches. We recommend everyone to inspect their systems and to upgrade. Besides 1.8, other older Ruby versions have also reached end-of-life: Ruby 1.9 in 2015, Ruby 2.0 in 2016, Ruby 2.1 in 2017 and Ruby 2.2 earlier this year.

Nevertheless, we will still support Ruby 1.9.3 and up for the time being, because we recognize that many customers can't easily upgrade. Please refer to Ruby's documentation on updating your installation.

Older versions of Passenger will continue to be available for download. If you need to use older operating systems or older Ruby versions, then you still have the option to use an older Passenger version.

What do you think? Should we go ahead or not? Please let us know by posting a comment in the Github issue tracker.